1002. A+B for Polynomials (25)

1.直接建立1001长度的数组,分别进行存储,最后累加输出。

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

 

AC代码:

[c language=”++”]
//#include<string>
//#include<stack>
//#include<unordered_set>
//#include <sstream>
//#include "func.h"
//#include <list>
#include <iomanip>
#include<unordered_map>
#include<set>
#include<queue>
#include<map>
#include<vector>
#include <algorithm>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
#include<stack>
using namespace std;

int main(void)
{
vector<float> N1(1002, 0);
vector<float> N2(1002, 0);
int n, m;
cin >> n;
//输入第一个多项式
for (int i = 0; i < n; i++)
{
int idx = 0;
cin >> idx;
cin >> N1[idx];
}

cin >> m;
//输入第二个多项式
for (int i = 0; i < m; i++)
{
int idx = 0;
cin >> idx;
cin >> N2[idx];
}

//同阶的系数相加
for (int i = 0; i < N1.size(); i++)
{
N1[i] = N1[i] + N2[i];
}

int sum = 0;
for (int i = 0; i < N1.size(); i++)
{
if (N1[i] != 0)
sum++;
}
cout << sum;
for (int i = N1.size() – 1; i >= 0; i–)
{//高位先输出
if (N1[i] != 0)//不为0,则输出
printf(" %d %.1f", i, N1[i]);
}
return 0;
}
[/c]

Leave a Reply

Your email address will not be published. Required fields are marked *