1006. Sign In and Sign Out (25)

1.采用algorithm.h里面的sort函数,对时间进行排序,需要重写比较函数。
2.计算最早到时,通过到达时间前后进行排序。
3.计算最晚走时,通过离开时间的晚早进行排序。

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133
//#include<string>
//#include <iomanip>
#include<vector>
#include <algorithm>
//#include<stack>
#include<set>
#include<queue>
#include<map>
//#include<unordered_set>
//#include<unordered_map>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
using namespace std;
int time2Int(string s)
{
	int hour = (s[0] - '0') * 10 + s[1] - '0';
	int min = (s[3] - '0') * 10 + s[4] - '0';
	int sec = (s[6] - '0') * 10 + s[7] - '0';
	return hour * 3600 + min * 60 + sec;
}
struct people{
	int begin, end;
	string ID;
	people() :begin(0), end(0), ID(""){};
};
bool cmpBegin(const people&a, const people&b)
{
	if (a.begin < b.begin) return true;
	else return false;
}
bool cmpEnd(const people&a, const people&b)
{
	if (a.end > b.end) return true;
	else return false;
}
int main(void) {

	int n;
	cin >> n;
	vector<people> p(n);
	for (int i = 0; i < n; i++)
	{
		string a, b, c;
		cin >> a >> b >> c;
		p[i].ID = a;
		p[i].begin = time2Int(b);
		p[i].end = time2Int(c);
	}
	string first = "";
	sort(p.begin(), p.end(), cmpBegin);
	first = p[0].ID;
	sort(p.begin(), p.end(), cmpEnd);
	string last = p[0].ID;
	cout << first << " " << last << endl;
	return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注