1009. Product of Polynomials (25)

1.题目要求两个多项式相乘的结果。

2.直接创建1000*1000+1的数组,然后遍历所有相乘的组合情况。

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

AC代码:

//#include<string>
//#include <iomanip>
#include<vector>
#include <algorithm>
//#include<stack>
#include<set>
#include<queue>
#include<map>
//#include<unordered_set>
//#include<unordered_map>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
using namespace std;
int main(void) {

	int n, m;
	cin >> n;
	vector<double> NK1(1001, 0);
	vector<double> NK2(1001, 0);
	vector<double> NK(1000001, 0);//直接创建1000*1000+1的数组
	//输入第一个多项式
	for (int i = 0; i < n; i++)
	{
		int temp;
		cin >> temp;
		cin >> NK1[temp];
	}

	cin >> m;
	//输入第二个多项式
	for (int i = 0; i < m; i++)
	{
		int temp;
		cin >> temp;
		cin >> NK2[temp];
	}
	//进行相乘
	for (int i = 0; i < 1001; i++)
	{
		for (int j = 0; j < 1001; j++)
		{
			if (NK1[i] != 0 && NK2[j] != 0)
			{
				NK[i + j] += NK1[i] * NK2[j];
			}
		}
	}

	int sum = 0;
	for (int i = 0; i < 1000001; i++)
	{//统计有多少项非零
		if (NK[i] != 0) sum++;
	}
	cout << sum;
	if (sum != 0) cout << " ";
	for (int i = 1000000; i >= 0; i--)
	{
		if (NK[i] != 0)
		{//输出非零的多项式
			printf("%d %.1lf", i, NK[i]);
			sum--;
			if (sum != 0) cout << " ";
		}

	}
	return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注