1027. Colors in Mars (20)

1.给出RGB十进制颜色,求出其13进制颜色,主要涉及到进制的转换,10进制到13进制。

2.处理0和个位数,前面需要补0。

3.可以自行输出0~168检测函数的鲁棒性。

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

Sample Input

15 43 71

Sample Output

#123456

[c language=”++”]
//#include<string>
//#include <iomanip>
#include<vector>
#include <algorithm>
//#include<stack>
#include<set>
#include<queue>
#include<map>
//#include<unordered_set>
//#include<unordered_map>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
using namespace std;
string int2str(int a)
{
char c;
if (a >= 0 && a <= 9)
c = a + ‘0’;
else
c = a – 10 + ‘A’;
string ans = "";
ans += c;
return ans;
}
string dec213(int a)
{
if (a == 0) return "00";
string ans = "";
while (a != 0)
{
ans += int2str(a % 13);
a /= 13;
}
for (int i = 0; i < ans.size() / 2; i++)
swap(ans[i], ans[ans.size() – 1 – i]);
if (ans.size() == 1) ans = ‘0’ + ans;
return ans;
}
int main(void)
{
int r, g, b;
cin >> r >> g >> b;
cout << "#" << dec213(r) << dec213(g) << dec213(b) << endl;
return 0;
}

[/c]

Leave a Reply

Your email address will not be published. Required fields are marked *