1.题目要求求一个数组中,第一个出现的仅出现一次(Unique)的数字。
2.统计各个数字出现的次数。
3.输出第一个出现次数为1的数字。
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.
Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.
Output Specification:
For each test case, print the winning number in a line. If there is no winner, print “None” instead.
Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
AC代码:
[c language=”++”]
//#include<string>
//#include <iomanip>
#include<vector>
#include <algorithm>
//#include<stack>
#include<set>
#include<queue>
#include<map>
//#include<unordered_set>
#include<unordered_map>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
using namespace std;
int main(void)
{
int *frequency = new int[100001];
memset(frequency, 0, 100001 * sizeof(int));
int sum;
cin >> sum;
int *num = new int[sum];
for (int i = 0; i<sum; i++)
{
scanf("%d", &num[i]);
frequency[num[i]]++;
}
for (int i = 0; i<sum; i++)
{
if (frequency[num[i]] == 1)
{
cout << num[i] << endl;
return 0;
}
}
cout << "None" << endl;
return 0;
}
[/c]