1083. List Grades (25)

1.题目要求根据一定的分数范围,对学生进行排序输出。

2.题目提到各个同学的分数是唯一的,所以可以采用分数作为下标,直接建立101个学生节点,即0~100分。

3.然后根据最高分限制和最低分限制,筛选出学生进行输出。

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output “NONE” instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

 
AC代码:

//#include<string>
//#include <iomanip>
//#include<stack>
//#include<unordered_set>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<unordered_map>
#include<set>
#include<queue>
#include<map>
#include<vector>
#include <algorithm>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
#include<stack>
using namespace std;
struct StudentNode{
	string id, name;
	StudentNode() :id(""), name(""){};
};
int main(void)
{
	vector<StudentNode> student(101);
	int n;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		int grade;
		string name, id;
		cin >> name >> id >> grade;
		student[grade].name = name;
		student[grade].id = id;
	}
	int minGrade , maxGrade;
	cin >> minGrade >> maxGrade;
	vector<StudentNode> ans(0);
	for (int i = maxGrade; i >= minGrade; i--)
	{
		if (student[i].name!="")
		{
			ans.push_back(student[i]);
		}
	}

	if (ans.size() == 0)
		cout << "NONE" << endl;
	else
	{
		for (int i = 0; i < ans.size(); i++)
			cout << ans[i].name << " " << ans[i].id << endl;
	}

	return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注