1089. Insert or Merge (25)

1.给出一个初始的排列和一个经过N轮排序的排列,求出是使用插入还是归并排序,并输出下一轮的排列。

2.注意插入排序j=1开始。

3.根据题意,编写归并排序算法,如下:

	bool isMerge = false;
	for (int step = 1; step / 2 < n; step *= 2)
	{//步进初始为1,第二次为2,第三次为4,如此类推
		for (int i = 0; i < n; i += 2 * step)
		{
			vector<int> tmpArr(2 * step);
			int first = i;
			int second = i+step;
			int idx = 0;
			int k = 0;
			while (first<min(n,i+step)||second<min(n,i+2*step))
			{//通过first和second指针,把数组分为两个,然后进行归并排序
				if (first<min(n, i + step) && second<min(n, i + 2 * step))
				{
					if (num2[first] < num2[second])
						tmpArr[idx++] = num2[first++];
					else
						tmpArr[idx++] = num2[second++];
				}
				else if (first<min(n, i + step))//second已经遍历完,剩下first数组
					tmpArr[idx++] = num2[first++];
				else//first已经遍历完,剩下second数组
					tmpArr[idx++] = num2[second++];
			}
			for (int k = 0; k < 2 * step&&i + k < n; k++)
				num2[i + k] = tmpArr[k];
		}
		if (!isMerge&&num2 == target)
			isMerge = true;
		else if (isMerge)
			break;
	}
时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

AC代码:

//#include<string>
//#include <iomanip>
#include<vector>
#include <algorithm>
//#include<stack>
#include<set>
#include<queue>
#include<map>
//#include<unordered_set>
#include<unordered_map>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
using namespace std;

int main(void)
{
	int n;
	cin >> n;
	vector<int> num(n);
	vector<int> num2(n);
	vector<int> target(n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &num[i]);
	}
	num2 = num;
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &target[i]);
	}
	bool isInsert = false;
	for (int i = 1; i < n; i++)
	{
		int j = i;
		int tmp = num[i];
		for (; j > 0 && num[j - 1] > tmp; j--)
		{
			num[j] = num[j - 1];
		}
		num[j] = tmp;
		if (!isInsert && target == num)
			isInsert=true;
		else if (isInsert)
			break;
	}
	if (isInsert)
	{
		cout << "Insertion Sort" << endl;
		for (int i = 0; i < num.size(); i++)
		{
			cout << num[i];
			if (i != num.size() - 1)
				cout << " ";
		}
		cout << endl;
		return 0;
	}


	bool isMerge = false;
	for (int step = 1; step / 2 < n; step *= 2)
	{//步进初始为1,第二次为2,第三次为4,如此类推
		for (int i = 0; i < n; i += 2 * step)
		{
			vector<int> tmpArr(2 * step);
			int first = i;
			int second = i+step;
			int idx = 0;
			int k = 0;
			while (first<min(n,i+step)||second<min(n,i+2*step))
			{//通过first和second指针,把数组分为两个,然后进行归并排序
				if (first<min(n, i + step) && second<min(n, i + 2 * step))
				{
					if (num2[first] < num2[second])
						tmpArr[idx++] = num2[first++];
					else
						tmpArr[idx++] = num2[second++];
				}
				else if (first<min(n, i + step))//second已经遍历完,剩下first数组
					tmpArr[idx++] = num2[first++];
				else//first已经遍历完,剩下second数组
					tmpArr[idx++] = num2[second++];
			}
			for (int k = 0; k < 2 * step&&i + k < n; k++)
				num2[i + k] = tmpArr[k];
		}
		if (!isMerge&&num2 == target)
			isMerge = true;
		else if (isMerge)
			break;
	}

	cout << "Merge Sort" << endl;
	for (int i = 0; i < num2.size(); i++)
	{
		cout << num2[i];
		if (i != num2.size() - 1)
			cout << " ";
	}
	cout << endl;

	return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注