1019. General Palindromic Number (20)

1.题目要求,求一个数N在B进制表示的情况下,是否构成回文。

2.采用求余的方式转换成以radix为基数的数

3.使用vector<int>来存储底数,因为后面需要以底数的形式显示,而不是以位的形式显示

print N as the number in base b in the form “ak ak-1 … a0“.

4.注意输入为0的情况

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line “Yes” if N is a palindromic number in base b, or “No” if not. Then in the next line, print N as the number in base b in the form “ak ak-1 … a0“. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

AC代码:

//#include<string>
//#include <iomanip>
#include<vector>
#include <algorithm>
//#include<stack>
#include<set>
#include<queue>
#include<map>
//#include<unordered_set>
//#include<unordered_map>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
using namespace std;
int main(void)
{
	long long number, radix;
	cin >> number >> radix;
	vector<int> base(0);
	if (number == 0) base.push_back(0);
	while (number != 0)
	{
		//余数很有可能超过char的范围,例如999%1000=999
		base.push_back(number%radix);
		number /= radix;
	}
	bool ans = true;
	for (int i = 0; i < base.size() / 2; i++)
	{
		if (ans && base[i] != base[base.size() - 1 - i])//判断回文
			ans = false;
		swap(base[i], base[base.size() - 1 - i]);//求出来的底数是倒序的,顺便把顺序调整过来
	}
	if (ans)
		cout << "Yes" << endl;
	else
		cout << "No" << endl;
	for (int i = 0; i < base.size(); i++)
	{
		cout << base[i];
		if (i != base.size() - 1)
			cout << " ";
	}
	cout << endl;

	return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注