1031. Hello World for U (20)

1.题目要求把一个字符串按照U型输出。

2..通过 n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 – 2 = N的条件,通过for循环求出最大的n1。

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible — that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 – 2 = N.Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

AC代码:
[c language=”++”]
//#include<string>
//#include <iomanip>
#include<vector>
#include <algorithm>
//#include<stack>
#include<set>
#include<queue>
#include<map>
//#include<unordered_set>
//#include<unordered_map>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
using namespace std;

int main(void)
{
string s;
cin >> s;
int n = s.size();
int n1 = 0, n2 = 0;
for (int i = 0; i < n; i++)
{//求出n1的最大值
n1 = i;
n2 = n + 2 – 2 * n1;
if (n2 < n1) break;
}
if (n2 < n1)
n1–;
n2 = n + 2 – 2 * n1;
string mid = "";
for (int i = 0; i < n2 – 2; i++)
mid += " ";

for (int i = 0; i < n1 – 1; i++)
{
cout << s[i] << mid << s[s.size() – 1 – i] << endl;
}
for (int i = n1 – 1; i < n1 – 1 + n2; i++)
{
cout << s[i];
}
cout << endl;
return 0;
}

[/c]

Leave a Reply

Your email address will not be published. Required fields are marked *