1039. Course List for Student (25)

1.题目给出一些课程和选修的学生名单,最后查询学生选修了什么课程。

2.存在超时的危险。

3.根据题意,名字由3个字母和1个数字组成,所以共26*26*26*10=175760种可能,直接开辟内存。

20151116133921234

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

AC代码:

//#include<string>
//#include <iomanip>
#include<vector>
#include <algorithm>
//#include<stack>
#include<set>
#include<queue>
#include<map>
//#include<unordered_set>
#include<unordered_map>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
using namespace std;
/*
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
*/
int main(void)
{

	int querySum, courseSum;
	cin >> querySum >> courseSum;
	vector<set<int>>stu(175761);//3个字母+1个数字,共26*26*26*10=175760种可能,直接开辟内存
	for (int i = 0; i<courseSum; i++)
	{
		int courseIdx, studentSum;
		scanf("%d %d", &courseIdx, &studentSum);
		for (int j = 0; j<studentSum; j++)
		{
			char tmp[5];
			scanf("%s", tmp);
			int name = (tmp[0]-'A')*26*26*10;
			name += (tmp[1] - 'A') * 26*10 + (tmp[2] - 'A') * 10 + tmp[3]-'0';
			stu[name].insert(courseIdx);
		}
	}

	for (int i = 0; i<querySum; i++)
	{
		char tmp[5];
		scanf("%s", tmp);
		int name = (tmp[0] - 'A') * 26 * 26 * 10;
		name += (tmp[1] - 'A') * 26 * 10 + (tmp[2] - 'A') * 10 + tmp[3] - '0';
		printf("%s %d",tmp,stu[name].size());
		for (set<int>::iterator ite = stu[name].begin(); ite != stu[name].end(); ite++)
		{
			printf(" %d", *ite);
		}
		cout << endl;
	}

	return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注