1046. Shortest Distance (20)

1.给出一个数组,求出0到i点的最短距离,可以直接从0->1->2->…->i,也可以0->n-1->n-2->n-3->…->i+1->i。

2.建立一个数组dp[i],记录0到i之间的距离和。

3.定义sum,记录全程的路程。

4.求i,j的最短距离时,利用ans=dp[j]-[i]+num[i]-num[j],ans2=sum-ans,min(ans,ans2)即为答案。

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

AC代码:

#include <iostream>
#include <stdio.h>
#include <vector>
#include <stack>
#include <algorithm>
#include <memory.h>
#include <map>
#include <set>
#include "limits.h"
using namespace std;

int main(void)
{
    
    int n;
    scanf("%d",&n);
    int *num=new int[n];
    int *dp=new int[n];
    memset(dp, 0, sizeof(dp));
    int sum=0;
    for(int i=0;i<n;i++)
    {
        scanf("%d",&num[i]);
        if(i==0) dp[i]=num[i];
        else dp[i]=dp[i-1]+num[i];
        sum+=num[i];
    }
    int m;
    scanf("%d",&m);
    for(int i=0;i<m;i++)
    {
        int a,b;
        scanf("%d %d",&a,&b);
        if(a>b) swap(a,b);
        int tmp=dp[b-1]-dp[a-1]+num[a-1]-num[b-1];
        int tmp2=sum-tmp;
        printf("%d\n",min(tmp2,tmp));
    }
    return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注