1048. Find Coins (25)

1.和leetcode的two sum一样,找出两个coin,使其价值等于amount。

2.采用哈希表记录已经遍历过的数据,target=pay-num[i],查找num[target]是否在哈希表中有,如果有,则压进ans容器,最后进行排序输出。

3.时间复杂度为o(n)。

1048find coins

 

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output “No Solution” instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

 

AC代码如下:

#include <iostream>
#include <stdio.h>
#include <vector>
#include <stack>
#include <algorithm>
#include <memory.h>
#include <map>
#include <set>
#include "limits.h"
using namespace std;
/*
 8 15 
 1 2 8 7 2 4 11 15
 
 
 7 14
 1 8 7 2 4 11 15
 */
bool cmp(const pair<int,int>&a,const pair<int,int>&b)
{
    return a.first<b.first;
}

int main(void)
{
    int coinSum,pay;
    scanf("%d %d",&coinSum,&pay);
    int *coin=new int[coinSum];
    int target;
    int *haveCoin=new int[501];
    memset(haveCoin, 0, sizeof(haveCoin));
    vector<pair<int,int>> ans(0);
    for(int i=0;i<coinSum;i++)
    {
        scanf("%d",&coin[i]);
        target=pay-coin[i];
        if(target>=0&&target<=500&&haveCoin[target]>0)
        {
            int a=min(coin[i],target);
            int b=pay-a;
            ans.push_back({a,b});
        }
        haveCoin[coin[i]]++;
    }
    sort(ans.begin(),ans.end(),cmp);
    if(ans.size()>0)
        printf("%d %d\n",ans[0].first,ans[0].second);
    else
        printf("No Solution\n");
    return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注