1075. PAT Judge (25)

1.主要是求排名,根据给定的规则排名。

2.该题有几个需要注意的点
1)-1表示提交了但是没有编译通过,在最终输出的时候需要显示0分
2)完全没有记录的,表示没有提交过,在最终输出的时候需要显示-(负号)
3)在排名时,要把0分的也进行排名,如下面的测试例子:

8 4 21
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
00008 4 0

正确答案应该为:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
6 00008 0 - - - 0

8号用户虽然0分,但是有提交过,所以排名是有的。

1075

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

AC代码:

//#include<string>
//#include <iomanip>
//#include<stack>
//#include<unordered_set>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<unordered_map>
#include<set>
#include<queue>
#include<map>
#include<vector>
#include <algorithm>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
#include<stack>
using namespace std;
/*
8 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0


8 4 21
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
00008 4 0

1 1 1
20
00001 1 15

*/
struct UserNode{
	int id;
	int rank;
	vector<int> score;
	int totalScore;
	int perfectSubmit;
	int noSubmit;
	UserNode() :id(0), rank(0), score(0), totalScore(0), perfectSubmit(0),noSubmit(0){};
	UserNode(vector<int> a) :id(0), rank(0), score(a), totalScore(0), perfectSubmit(0), noSubmit(0){};
};
bool cmp(const UserNode&a, const UserNode&b)
{
	if (a.totalScore > b.totalScore)
		return true;
	else if (a.totalScore == b.totalScore)
	{
		if (a.perfectSubmit > b.perfectSubmit)
			return true;
		else if (a.perfectSubmit == b.perfectSubmit && a.id < b.id)
			return true;
		else 
			return false;
	}
	else return false;
}
int main(void)
{
	int userSum, problemSum, submitSum;
	cin >> userSum >> problemSum >> submitSum;
	vector<UserNode> user(userSum);
	for (int i = 0; i < user.size(); i++)
	{//初始化每个用户的每个题目的分数
		user[i].score = vector<int>(problemSum, -2);
	}
	vector<int> fullScore(problemSum);
	for (int i = 0; i < fullScore.size(); i++)
	{//输入满分的分值
		cin >> fullScore[i];
	}

	for (int i = 0; i < submitSum; i++)
	{//输入提交记录
		int id,problemID, score;
		scanf("%d %d %d", &id, &problemID, &score);
		user[id - 1].id = id;//记录id
		user[id - 1].score[problemID - 1] = max(user[id - 1].score[problemID - 1],score);//取最高分,-1表示没有通过编译
	}
	for (int i = 0; i < user.size(); i++)
	{//统计学生的具体成绩
		user[i].totalScore = 0;
		for (int j = 0; j < problemSum; j++)
		{
			if (user[i].score[j] >=0)//大于等于0,即通过编译器
				user[i].totalScore += user[i].score[j];
			else //-1为提交了没通过编译器,-2为没提交
				user[i].noSubmit++;

			if (user[i].score[j] == fullScore[j])//如果分数是满分,perfect++
				user[i].perfectSubmit++;
		}
	}
	sort(user.begin(), user.end(), cmp);
	user[0].rank = 1;//一个用户排名第一
	printf("%d %05d %d", user[0].rank, user[0].id, user[0].totalScore);
	for (int j = 0; j < problemSum; j++)
	{
		if (user[0].score[j] >=0)
			printf(" %d", user[0].score[j]);
		else if (user[0].score[j] == -1)
			printf(" 0");//-1,提交了不通过,0分
		else//-2,没有提交过
			printf(" -");
	}
	printf("\n");
	for (int i = 1; i < user.size(); i++)
	{
		//即使分数为0的,也要统计排名
		if (user[i].totalScore == user[i-1].totalScore)
			user[i].rank = user[i - 1].rank;
		else
			user[i].rank = i+1;

		if (user[i].noSubmit != problemSum)
		{		//输出用户信息
			printf("%d %05d %d", user[i].rank, user[i].id, user[i].totalScore);
			for (int j = 0; j < problemSum; j++)
			{
				if (user[i].score[j] >= 0)//如果用户的分数大于等于0,则输出分数
					printf(" %d", user[i].score[j]);
				else if (user[i].score[j] == -1)
					printf(" 0");//-1,提交了不通过,0分
				else //-2,没有提交过,输出横线
					printf(" -");
			}
			printf("\n");
		}
	}
	return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注