1094. The Largest Generation (25)

1.这道题目主要是求家族树中,哪一层的成员数最多,输出成员数和该层层数。

2.主要考察了层次遍历和数据结构的设计。

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

AC代码:

//#include<string>
//#include <iomanip>
#include<vector>
#include <algorithm>
//#include<stack>
#include<set>
#include<queue>
#include<map>
//#include<unordered_set>
#include<unordered_map>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
using namespace std;

struct Node{
	vector<int> list;
	Node() :list(0){};
};
int main(void)
{
	int totalNum, recordNum;
	cin >> totalNum >> recordNum;
	vector<Node> tree(totalNum+1);
	for (int i = 0; i < recordNum; i++)
	{
		int id, n;
		cin >> id >> n;
		for (int j = 0; j < n; j++)
		{
			int tmp;
			cin >> tmp;
			tree[id].list.push_back(tmp);
		}
	}

	queue<int> q;
	q.push(1);
	int count1 = 1;
	int count2 = 0;
	int maxFamilyMember = 1, maxFamilyLevel = 1;
	int level = 1;
	while (!q.empty())
	{
		for (int i = 0; i < count1; i++)
		{
			int root = q.front(); q.pop();
			for (int j = 0; j < tree[root].list.size(); j++)
			{
				q.push(tree[root].list[j]);
			}
			count2 += tree[root].list.size();
		}
		level++;
		if (count2 > maxFamilyMember)
		{
			maxFamilyMember = count2;
			maxFamilyLevel = level;
		}
		count1 = count2;
		count2 = 0;
	}
	cout << maxFamilyMember << " " << maxFamilyLevel << endl;



	return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注