#1288 : Font Size

1.通过分析这道题目的规模,采用朴素方法的时间复杂度为O(n^2),即10^6,理论上可以通过,于是先采用朴素方法进行求解。

描述

Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven’s phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)

So here’s the question, if Steven wants to control the number of pages no more than P, what’s the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

输入

Input may contain multiple test cases.

The first line is an integer TASKS, representing the number of test cases.

For each test case, the first line contains four integers N, P, W and H, as described above.

The second line contains N integers a1, a2, … aN, indicating the number of characters in each paragraph.

For all test cases,

1 <= N <= 103,

1 <= W, H, ai <= 103,

1 <= P <= 106,

There is always a way to control the number of pages no more than P.

输出

For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

样例输入

2
1 10 4 3
10
2 10 4 3
10 10

样例输出

3
2

 
AC代码:

#include <stdio.h>
#include <iostream>
#include <vector>
#include <stack>
#include <algorithm>
#include <string>
#include <unordered_map>
#include <set>
#include <map>
#include <memory.h>
using namespace std;

int main()
{
	int t = 0;
	scanf("%d", &t);
	long long a[1001];
	while (t--)
	{
		memset(a, 0, sizeof(a));
		int n, p, w, h;
		scanf("%d%d%d%d", &n, &p, &w, &h);
		for (int i = 0; i < n; ++i)
			scanf("%d", &a[i]);

		int maxSize = min(w, h);
		bool flag = true;
		int size = maxSize;
		for (size = maxSize; size >=1; size--)
		{
			flag = true;
			int eachLineWords = w / size;//每行能放的单词数量
			int lineWords = h / size;//每页能放的行数
			long long totalLine = p*lineWords;//一共能放的单词行数

			int sumCount = 0;
			int tmp = 0;
			for (int i = 0; i < n; ++i)
			{
				tmp = a[i] / eachLineWords;
				if (a[i] % eachLineWords != 0)
					sumCount += (tmp + 1);
				else
					sumCount += tmp;
				if (sumCount > totalLine)
					flag = false;
			}
			if (flag) break;
		}
		if (flag)
			printf("%d\n", size);
		else
			printf("%d\n", 0);
	}

	return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注