1.该题是供应链问题,实则是构建一棵树,然后使用BFS进行层序遍历,找出最早出现叶子节点的层,统计该层的叶子节点,然后直接输出结果。
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer.
Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.
Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.
Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:
Ki ID[1] ID[2] … ID[Ki]
where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.
Sample Input:
10 1.80 1.00 3 2 3 5 1 9 1 4 1 7 0 2 6 1 1 8 0 0 0
Sample Output:
1.8362 2
AC代码:
[c language=”++”]
//#include<string>
//#include <iomanip>
#include<vector>
#include <algorithm>
//#include<stack>
#include<set>
#include<queue>
#include<map>
//#include<unordered_set>
#include<unordered_map>
//#include <sstream>
//#include "func.h"
//#include <list>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
using namespace std;
bool cmp(const int&a, const int&b)
{
return a > b;
}
struct ChainNode{
vector<int> list;
ChainNode() :list(0){};
};
int main(void)
{
int total;
double rootPrice, higher;
scanf("%d %lf %lf", &total, &rootPrice, &higher);
vector<ChainNode> chain(total);
for (int i = 0; i < total; i++)
{
int nextTotal;//下游数量
scanf("%d", &nextTotal);
for (int j = 0; j < nextTotal; j++)
{
int tmp;
scanf("%d", &tmp);
chain[i].list.push_back(tmp);//记录下游节点
}
}
queue<int> q;
q.push(0);
int count1 = 1;
int count2 = 0;
int retailerSum = 0;//该层零售商数量
while (!q.empty())
{
for (int i = 0; i < count1; i++)
{
int head = q.front();
q.pop();
if (chain[head].list.size() == 0)
retailerSum++;//如果出现子节点,则进行计数记录
else
{//否则压入队列,下次遍历
for (int j = 0; j < chain[head].list.size(); j++)
{
count2++;
q.push(chain[head].list[j]);
}
}
}
//如果存在叶子节点,直接跳出
if (retailerSum != 0) break;
count1 = count2;
count2 = 0;
rootPrice *= (1 + higher / 100.0);
}
printf("%.4lf %d\n", rootPrice, retailerSum);
return 0;
}
[/c]