1.该题求出现次数超过一半的元素,故采用moore voting算法,moore投票法。
2.遇到不同的元素,如果出现次数为0,更跟换成当前元素,如果次数不为0则-1。
3.遇到相同元素,出现次数相加。
4.最终记录的元素就是所求元素。
Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input:
5 3 0 0 255 16777215 24 24 24 0 0 24 24 0 24 24 24
Sample Output:
24
[c language=”++”]
//#include<string>
//#include<stack>
//#include<unordered_set>
//#include <sstream>
//#include "func.h"
//#include <list>
#include <iomanip>
#include<unordered_map>
#include<set>
#include<queue>
#include<map>
#include<vector>
#include <algorithm>
#include<stdio.h>
#include<iostream>
#include<string>
#include<memory.h>
#include<limits.h>
#include<stack>
using namespace std;
int main(void)
{
int m, n;
cin >> m >> n;
int count = 0, color = -1;
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m; j++)
{
int tmpColor;
scanf("%d", &tmpColor);
if (color != tmpColor)
{//元素不同
if (count == 0)//更新元素
color = tmpColor;
else
count–;
}
else//元素相同,出现次数累加
count++;
}
}
cout << color << endl;
return 0;
}
[/c]